Khắc phục lỗi “Requires: kernel-headers >=…” khi cập nhật glibc-header trên CentOS

Sáng nay cài VestaCP cho con VPS CentOS 7, đang cài ngon trớn xuất hiện cái lỗi này…

Package: glibc-header-2.17-106.el7_2.6x886_64 (updates) Requires: kernel-headers >= 2.2.1

requires -kernel-headers

Khựng lại vài giây, như thường lệ search google với các từ khóa liên quan thì tìm ra cách fix.

Đơn giản nhất thì chỉ cần chạy lệnh:

Thôi chuẩn bị đi về, thứ 7 được nghỉ buổi chiều :3

À quên, bạn nào muốn thử cách khác thì tham khảo thêm nha :v

Your system is probably configured to exclude the kernel packages.

Try:

sudo vi /etc/yum.conf
then comment (or remove the ‘kernel*’ part):

#exclude=kernel*
Then you should be able to do:

sudo yum install kernel-headers

Nguồn tham khảo: http://stackoverflow.com/questions/6513731/linux-yum-install-gcc-missing-kernel-headers

 

 

jamesblackvn
Tui là jamesblackvn!

Gửi phản hồi